Skip to content
Navigation Menu
Sign in
Appearance settings
Platform
AI CODE CREATION
GitHub Copilot
Write better code with AI
GitHub Copilot app
Direct agents from issue to merge
MCP Registry
Integrate external tools
DEVELOPER WORKFLOWS
Actions
Automate any workflow
Codespaces
Instant dev environments
Issues
Plan and track work
Code Review
Manage code changes
Code Quality
Enforce quality at merge
APPLICATION SECURITY
GitHub Advanced Security
Find and fix vulnerabilities
Code security
Secure your code as you build
Secret protection
Stop leaks before they start
EXPLORE
Why GitHub
Documentation
Blog
Changelog
Marketplace
View all features
Solutions
BY COMPANY SIZE
Enterprises
Small and medium teams
Startups
Nonprofits
BY USE CASE
App Modernization
DevSecOps
DevOps
CI/CD
View all use cases
BY INDUSTRY
Healthcare
Financial services
Manufacturing
Government
View all industries
View all solutions
Resources
EXPLORE BY TOPIC
AI
Software Development
DevOps
Security
View all topics
EXPLORE BY TYPE
Customer stories
Events & webinars
Ebooks & reports
Business insights
GitHub Skills
SUPPORT & SERVICES
Documentation
Customer support
Community forum
Trust center
Partners
View all resources
Open Source
COMMUNITY
GitHub Sponsors
Fund open source developers
PROGRAMS
Security Lab
Maintainer Community
GitHub Stars
Archive Program
REPOSITORIES
Topics
Trending
Collections
Enterprise
ENTERPRISE SOLUTIONS
Enterprise platform
AI-powered developer platform
AVAILABLE ADD-ONS
GitHub Advanced Security
Enterprise-grade security features
Copilot for Business
Enterprise-grade AI features
Premium Support
Enterprise-grade 24/7 support
Pricing
Search
/
Sign in
Sign up
Appearance settings
You signed in with another tab or window.
Reload
to refresh your session.
You signed out in another tab or window.
Reload
to refresh your session.
You switched accounts on another tab or window.
Reload
to refresh your session.
Dismiss alert
{{ message }}
Uh oh!
There was an error while loading.
Please reload this page
.
emberjs
/
ember.js
Public
Uh oh!
There was an error while loading.
Please reload this page
.
Notifications
You must be signed in to change notification settings
Fork
4.2k
Star
22.6k
Code
Issues
187
Pull requests
91
Actions
Projects
Security and quality
0
Insights
Additional navigation options
Code
Issues
Pull requests
Actions
Projects
Security and quality
Insights
Commits
Branch selector
main
User selector
wagenet
Datepicker
All time
Commit history
Commits on Aug 14, 2026
Deprecate Evented and @ember/object/events per RFC 1111
Show description for a593675
wagenet
authored and
NullVoxPopuli
committed
a593675
View commit details
Copy full SHA for a593675
Browse repository at this point
Commits on Jul 7, 2026
Deprecate TargetActionSupport per RFC 1041
Show description for 87de0e5
wagenet
authored and
NullVoxPopuli
committed
87de0e5
View commit details
Copy full SHA for 87de0e5
Browse repository at this point
Commits on Mar 17, 2026
Update router_js
wagenet
authored and
NullVoxPopuli
committed
dde8702
View commit details
Copy full SHA for dde8702
Browse repository at this point
Commits on Jun 11, 2025
Merge pull request #20926 from wagenet/kill-view-mixins-main
Show description for ad60313
wagenet
authored
ad60313
View commit details
Copy full SHA for ad60313
Browse repository at this point
Fix TS 5.0
wagenet
committed
8c6f3da
View commit details
Copy full SHA for 8c6f3da
Browse repository at this point
Commits on Jun 10, 2025
Kill ViewMixin
wagenet
committed
bab64a2
View commit details
Copy full SHA for bab64a2
Browse repository at this point
Kill ViewStateSupport mixin
wagenet
committed
4a8a900
View commit details
Copy full SHA for 4a8a900
Browse repository at this point
Kill ClassNamesSupport
wagenet
committed
3a575b0
View commit details
Copy full SHA for 3a575b0
Browse repository at this point
Kill ChildViewsSupport mixin
wagenet
committed
5029864
View commit details
Copy full SHA for 5029864
Browse repository at this point
Merge pull request #20922 from emberjs/less-extend
Show description for ff02141
wagenet
authored
ff02141
View commit details
Copy full SHA for ff02141
Browse repository at this point
Even less extend
wagenet
committed
70bae8a
View commit details
Copy full SHA for 70bae8a
Browse repository at this point
Merge pull request #20920 from wagenet/less-extend
Show description for f12fe86
wagenet
authored
f12fe86
View commit details
Copy full SHA for f12fe86
Browse repository at this point
Fix bad super call
wagenet
committed
67cf0d7
View commit details
Copy full SHA for 67cf0d7
Browse repository at this point
Commits on Jun 9, 2025
Remove many uses of .extend
wagenet
committed
eecccda
View commit details
Copy full SHA for eecccda
Browse repository at this point
Commits on Aug 21, 2024
Remove lint disable
wagenet
committed
c1a9e74
View commit details
Copy full SHA for c1a9e74
Browse repository at this point
Directly assign a boolean value in deprecated-features
wagenet
committed
a3bb306
View commit details
Copy full SHA for a3bb306
Browse repository at this point
Commits on Aug 2, 2024
Release 8.0.6
wagenet
committed
1dabe2a
View commit details
Copy full SHA for 1dabe2a
Browse repository at this point
Merge pull request #335 from davidtaylorhq/redirect-following-fix
Show description for 000a873
wagenet
authored
000a873
View commit details
Copy full SHA for 000a873
Browse repository at this point
Commits on Mar 21, 2024
Merge pull request #20664 from emberjs/upgrade-router-js-again
Show description for efc89be
wagenet
authored
efc89be
View commit details
Copy full SHA for efc89be
Browse repository at this point
Commits on Mar 19, 2024
Upgrade router_js to support `exactOptionalPropertyTypes`
wagenet
committed
c9e467b
View commit details
Copy full SHA for c9e467b
Browse repository at this point
Release 8.0.5
wagenet
committed
cea9932
View commit details
Copy full SHA for cea9932
Browse repository at this point
Merge pull request #339 from boris-petrov/exactOptionalPropertyTypes
Show description for 7b65768
wagenet
authored
7b65768
View commit details
Copy full SHA for 7b65768
Browse repository at this point
Commits on Mar 6, 2024
Update router.js
wagenet
committed
9bfba8d
View commit details
Copy full SHA for 9bfba8d
Browse repository at this point
Release 8.0.4
wagenet
committed
7f786cc
View commit details
Copy full SHA for 7f786cc
Browse repository at this point
Merge pull request #336 from chbonser/recognize-qp-issue
Show description for f39f2df
wagenet
authored
f39f2df
View commit details
Copy full SHA for f39f2df
Browse repository at this point
Commits on Dec 15, 2023
Merge pull request #20605 from emberjs/template-compilation-dep
Show description for f88ca4c
wagenet
authored
f88ca4c
View commit details
Copy full SHA for f88ca4c
Browse repository at this point
Commits on Aug 25, 2023
Merge pull request #20532 from NullVoxPopuli/re-roll-lockfile-took-1m12s-oof
Show description for 288644f
wagenet
authored
288644f
View commit details
Copy full SHA for 288644f
Browse repository at this point
Merge pull request #20530 from NullVoxPopuli/upgrade-glimmer-vm
Show description for 496768b
wagenet
authored
496768b
View commit details
Copy full SHA for 496768b
Browse repository at this point
Commits on Aug 23, 2023
Merge pull request #20529 from gitKrystan/error-error
Show description for 40ba038
wagenet
authored
40ba038
View commit details
Copy full SHA for 40ba038
Browse repository at this point
Commits on Aug 18, 2023
Merge pull request #20210 from patricklx/patch-3
Show description for 5709138
wagenet
authored
5709138
View commit details
Copy full SHA for 5709138
Browse repository at this point
Commits on Jul 25, 2023
Merge pull request #20376 from emberjs/deprecate-implicit-loading-route
Show description for 408d304
wagenet
authored
408d304
View commit details
Copy full SHA for 408d304
Browse repository at this point
Commits on Jul 20, 2023
[RFC-774] Deprecate implicit record loading in Ember Route
wagenet
committed
464fe3e
View commit details
Copy full SHA for 464fe3e
Browse repository at this point
Commits on Jul 11, 2023
Merge pull request #20501 from boris-petrov/fix-native-array-mutation-method-types
Show description for 9e51c36
wagenet
authored
9e51c36
View commit details
Copy full SHA for 9e51c36
Browse repository at this point
Commits on Jun 7, 2023
Merge pull request #20464 from NullVoxPopuli/qiawan/reexport_uniq_ids
Show description for a5364b4
wagenet
authored
a5364b4
View commit details
Copy full SHA for a5364b4
Browse repository at this point
Commits on Mar 21, 2023
Merge pull request #20415 from emberjs/remove-unused-imports
wagenet
authored
87a2d97
View commit details
Copy full SHA for 87a2d97
Browse repository at this point
Previous
Next
You can’t perform that action at this time.